Work on a project simulaniousely with VS 2010 and Expression Blend

If you are using the Beta 1 or 2 of Visual Studio 2010 you may want to use Expression Blend as you designer.
But if you try to open a project created by VS 2010 you will get the following error

The solution “MyProject.sln” is of an unsupported format and may not open correctly. Do you want to open the solution anyway?

Usually it crashes if you click Yes 🙂

The solution for this particular problem is simple.
You just have to set the .NET framework version of your project. Open if with Visual Studio, go to the settings of the project and set a version which is supported by Blend (.Net 3.0 or .Net 3.5).

//EDIT:
I have seen that Microsoft released a preview version of Expression Blend which can be used to work with .Net 4 projects
You can download it here: http://www.microsoft.com/Expression/try-it/default.aspx#PageTop
Note that it only works for .NET 4 projects. For .NET 3 projects you have to use the old version (Blend 3) because at the moment it does not support the old projects!

Advertisements
  1. No trackbacks yet.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: